We have successfully completed the recovery process for the intermittent task failures that occurred between March 24-26, 2026. Our team replayed all affected tasks, which have been successful with no data loss.
**What Happened**
Between March 24 at 11:02 AM UTC and March 26 at 2:04 PM UTC, some tasks failed for customers using Zaps that depend on our developercli service.
**Resolution**
We fixed the underlying issue causing this failure and completed a full replay of all impacted tasks. No action is needed on your side if affected — tasks have been automatically recovered and are now running normally.
Thank you for your patience while we worked through this issue. If you do have any other questions or see any issues, please reach out to our Support team at zapier.com/app/get-help
Resolved
We have successfully completed the recovery process for the intermittent task failures that occurred between March 24-26, 2026. Our team replayed all affected tasks, which have been successful with no data loss.
**What Happened**
Between March 24 at 11:02 AM UTC and March 26 at 2:04 PM UTC, some tasks failed for customers using Zaps that depend on our developercli service.
**Resolution**
We fixed the underlying issue causing this failure and completed a full replay of all impacted tasks. No action is needed on your side if affected — tasks have been automatically recovered and are now running normally.
Thank you for your patience while we worked through this issue. If you do have any other questions or see any issues, please reach out to our Support team at zapier.com/app/get-help
Identified
We‘re investigating intermittent task failures affecting some Zaps that occurred between March 24 and March 26, 2026. We have identified the root cause as exhausted database connections in our developercli service and have deployed a fix.
What happened: Between March 24 at 11:02 AM UTC and March 26 at 2:04 PM UTC, some tasks failed intermittently due to exhaustion of the database connection pool. This affected a subset of customer Zaps, though the majority of our platform remained operational.
Current status: The underlying issue has been resolved. We‘re currently replaying affected tasks to ensure they complete successfully. Most tasks with auto-replay enabled are being automatically reprocessed.
What you may have experienced: If you use developercli-dependent Zaps, you may have seen task failures during this window. We apologize for any disruption this caused to your workflows.
Next steps: We‘re completing task replays and will provide a full update once all affected tasks have been reprocessed. We do not expect any further issues.
Thank you for your patience as we work through this issue. If you have any questions, please reach out to our support team - zapier.com/app/get-help.