Starting on March 24th at 2:00am UTC an issue began impacting some customers where payments may fail during checkout, subscription renewals, or plan changes.
Customers may see a generic “unable to process payment” error and invoices may remain unpaid due to repeated failed attempts.
If you are seeing this error, re-adding your payment method should resolve the issue and allow you to checkout.
We are also emailing all users directly who are affected.
If you have any questions feel free to reach out to our support team. - zapier.com/app/get-help.
No components marked as affected
Identified
Starting on March 24th at 2:00am UTC an issue began impacting some customers where payments may fail during checkout, subscription renewals, or plan changes.
Customers may see a generic “unable to process payment” error and invoices may remain unpaid due to repeated failed attempts.
If you are seeing this error, re-adding your payment method should resolve the issue and allow you to checkout.
We are also emailing all users directly who are affected.
If you have any questions feel free to reach out to our support team. - zapier.com/app/get-help.
Investigating
We’re investigating an issue impacting a subset of customers where payments may fail during checkout, subscription renewals, or plan changes.
Customers may see a generic “unable to process payment” error and invoices may remain unpaid due to repeated failed attempts.
If you are seeing this error, re-adding your payment method should resolve the issue and allow you to checkout.
Our team is working to resolve this error internally as well.
If you have any questions feel free to reach out to our support team. - zapier.com/app/get-help.