We’ve deployed a fix for the issue that prevented some users from adding or removing tools on Zapier MCP servers, and we’ve confirmed the issue is resolved.
We apologize for the disruption and appreciate your patience as we got this resolved.
If you see any further issues, please reach out to our support team at https://zapier.com/app/get-help
Resolved
We’ve deployed a fix for the issue that prevented some users from adding or removing tools on Zapier MCP servers, and we’ve confirmed the issue is resolved.
We apologize for the disruption and appreciate your patience as we got this resolved.
If you see any further issues, please reach out to our support team at https://zapier.com/app/get-help
Monitoring
We’ve identified the cause of the issue preventing some users from adding or removing tools on Zapier MCP servers, and we have a fix in progress.
We’ll continue monitoring and will provide another update once we’ve confirmed full recovery.
If you have any other questions on this in the meantime, please reach out to our Support team at https://zapier.com/get-help.
Investigating
We’re investigating an issue where some users are unable to add or remove tools on Zapier MCP servers. Affected users may see a message prompting them to “switch to the account that owns the server” and may be disconnected after authentication.
Our team has identified and reproduced the issue and is actively working on a fix. We’ll share another update as we learn more.