Resolved - We have confirmed that the issue causing a blank OAuth Authorization page on zapier.com and during new connection setup has been fully resolved. If you run into any issues, please reach out to us here: https://zapier.com/app/get-help
Resolved
Resolved - We have confirmed that the issue causing a blank OAuth Authorization page on zapier.com and during new connection setup has been fully resolved. If you run into any issues, please reach out to us here: https://zapier.com/app/get-help
Monitoring
We have implemented a fix for the issue causing a blank OAuth Authorization page on zapier.com and when creating new connections. As of March 18, 2026 at 22:17:52 UTC, we believe the issue to be resolved, and we are continuing to monitor to ensure stability.
Investigating
We’re continuing to investigate the issue where users are seeing a blank OAuth Authorization page on zapier.com and when attempting to create new connections. Our team is actively prioritizing this issue and will share updates as soon as we have more information.
Investigating
We're currently investigating an issue where users are seeing a blank OAuth Authorization page on zapier.com and when attempting to create new connections.
We will provide an updated status by 2:30 PM PST