The Zap History and Task Usage pages are now loading normally again. During this incident, you may have experienced slow load times, intermittent errors, or missing data on the Zap History and Task Usage pages. Zap executions were not affected and continued to run as expected throughout.
This issue is now considered resolved, and we are continuing to monitor to ensure stability.
If you're still seeing delays or errors on these pages, we recommend clearing your browser's cache and cookies and logging back into Zapier. For any other issues or questions, please reach out to our support team at https://zapier.com/app/get-help.
No components marked as affected
Resolved
The Zap History and Task Usage pages are now loading normally again. During this incident, you may have experienced slow load times, intermittent errors, or missing data on the Zap History and Task Usage pages. Zap executions were not affected and continued to run as expected throughout.
This issue is now considered resolved, and we are continuing to monitor to ensure stability.
If you're still seeing delays or errors on these pages, we recommend clearing your browser's cache and cookies and logging back into Zapier. For any other issues or questions, please reach out to our support team at https://zapier.com/app/get-help.
Investigating
We are currently investigating delays affecting the display of Zap run history, and errors on the Zap Usage page. You may be seeing a delay in loading times on both pages.
Zap executions are running normally and completing as expected.
We appreciate your patience as we work through this issue. We'll provide updates as the situation progresses.