The checkout page payment and tax modals are now functioning normally again. During this incident, you may have been unable to add or update payment or tax information during checkout.
If you still have trouble updating payment or tax details, you can update your payment method from the billing settings page and then return to checkout.
We apologize for the disruption and appreciate your patience as we got this resolved. If you do see any further issues, please reach out to our support team at https://zapier.com/app/get-help
No components marked as affected
Resolved
The checkout page payment and tax modals are now functioning normally again. During this incident, you may have been unable to add or update payment or tax information during checkout.
If you still have trouble updating payment or tax details, you can update your payment method from the billing settings page and then return to checkout.
We apologize for the disruption and appreciate your patience as we got this resolved. If you do see any further issues, please reach out to our support team at https://zapier.com/app/get-help
Investigating
We’re currently investigating an issue affecting checkout where the payment and tax modals may not appear correctly. Self-serve customers who need to add or update payment or tax information during checkout may be unable to complete checkout.
Workaround: If you can’t add a card during checkout, you can add a payment method from the billing settings page and then return to checkout.
We’ll share another update as soon as we have more information.