Zaps using notion triggers stopped triggering
Monitoring

Our Engineering team has worked together with our Partners at Notion and identified the root cause. From 2026-02-25 21:07 To 2026-02-26 09:51 EST, Zaps using Notion triggers stopped triggering, or triggered intermittently due to a temporary error.


At this stage, all Zaps using Notion triggers are back to normal. We will continue to monitor trigger activity and update this status page to confirm resolution.

For any questions, please reach out support team at: zapier.com/get-help.

Thu, Feb 26, 2026, 03:33 PM
(8 hours ago)
·
Affected components

No components marked as affected

Updates

Monitoring

Our Engineering team has worked together with our Partners at Notion and identified the root cause. From 2026-02-25 21:07 To 2026-02-26 09:51 EST, Zaps using Notion triggers stopped triggering, or triggered intermittently due to a temporary error.


At this stage, all Zaps using Notion triggers are back to normal. We will continue to monitor trigger activity and update this status page to confirm resolution.

For any questions, please reach out support team at: zapier.com/get-help.

Thu, Feb 26, 2026, 03:33 PM

Investigating

Our team is currently investigating an issue where Zaps using Notion triggers stopped triggering approximately 3 hours ago.

We're currently seeing improvement and starting to receive hooks from Notion again, and we're working together with our Partners to restore the Zaps back to normal.

Many thanks for your patience, and feel free to reach us at zapier.com/get-help if you have any questions!

Thu, Feb 26, 2026, 03:13 PM(19 minutes earlier)