On February 20, 2026, between 1:44 PM and 8:27 PM EST, an Airtable outage caused authentication errors and trigger delays for customers using Airtable integrations through Zapier. Affected Airtable authentications were marked as inactive, resulting in errors and delays for impacted automations. The Zapier platform remained fully operational throughout.
Airtable's services have since fully recovered. If you are still experiencing issues with your Airtable connections, please visit the Zapier Connections page to reconnect Airtable, and check your Zap History to replay any affected runs.
No components marked as affected
Resolved
On February 20, 2026, between 1:44 PM and 8:27 PM EST, an Airtable outage caused authentication errors and trigger delays for customers using Airtable integrations through Zapier. Affected Airtable authentications were marked as inactive, resulting in errors and delays for impacted automations. The Zapier platform remained fully operational throughout.
Airtable's services have since fully recovered. If you are still experiencing issues with your Airtable connections, please visit the Zapier Connections page to reconnect Airtable, and check your Zap History to replay any affected runs.
Identified
We’re continuing to monitor an ongoing incident on Airtable’s end that is causing downstream effects within Zapier.
At this time, Airtable triggers may still experience slight delays and intermittent authentication errors. We’re awaiting full resolution from Airtable before moving on to next steps.
For the latest updates, please refer to Airtable’s status page:
https://status.airtable.com/
If you have any questions, feel free to reach out to our support team. https://zapier.com/app/get-help
Identified
Airtable is currently running into an incident which is causing downstream effects within Zapier. Airtable triggers are currently seeing slight delays and authentication errors.
You can follow their status page for updates:
https://status.airtable.com/
If you have any questions, feel free to reach out to our support team. https://zapier.com/app/get-help