Change History Not Displaying
Resolved·Degraded performance

This issue has been resolved.
Between 14:42 and 18:00 UTC on February 12, some users were unable to view the Change History panel in the editor.
All systems are now operating normally. If you experienced issues during this time, please refresh your browser.
Need help? Contact Support: https://zapier.com/app/get-help

Thu, Feb 12, 2026, 06:19 PM
(4 hours ago)
·
Affected components
Updates

Resolved

This issue has been resolved.
Between 14:42 and 18:00 UTC on February 12, some users were unable to view the Change History panel in the editor.
All systems are now operating normally. If you experienced issues during this time, please refresh your browser.
Need help? Contact Support: https://zapier.com/app/get-help

Thu, Feb 12, 2026, 06:19 PM

Investigating

We are currently investigating an issue affecting the Change History feature in the editor. Users may be unable to view the change history in the left editor sidebar. We will provide updates as we learn more. Thank you for your patience.

Thu, Feb 12, 2026, 06:02 PM(16 minutes earlier)