We're happy to report that the issue related to failures associated with logging in to http://mcp.zapier.com/ has been resolved.
Functionality has been fully restored, and users can now login without error.
If you have any questions or need assistance, please reach out to our Support team at
https://zapier.com/app/get-help
Resolved
We're happy to report that the issue related to failures associated with logging in to http://mcp.zapier.com/ has been resolved.
Functionality has been fully restored, and users can now login without error.
If you have any questions or need assistance, please reach out to our Support team at
https://zapier.com/app/get-help
Monitoring
Identified: Jan 29, 2026, 23:36:19.834 UTC
Monitoring: Jan 30, 2026, 16:38:00 UTC
Update:
We’ve identified and addressed the issue preventing some newly signed-up customers from logging in to mcp.zapier.com. The fix has been deployed, and login attempts are now succeeding as expected.
We’re continuing to monitor the situation to ensure everything remains stable. All other Zapier services are operating normally.
Investigating
We're investigating an issue affecting OAuth login on mcp.zapier.com for newly signed-up customers.
Impact: New customers who signed up after 18:00 UTC on January 29 may experience OAuth login failures when accessing MCP (our agent platform).
Unaffected: All other Zapier services are operating normally. Existing customers are not impacted.
Status: Our engineering team is actively investigating the root cause, which appears to be related to a recent change in how new accounts are synchronized between our systems. We are working to identify and fix the underlying issue.
Next steps: We’ll share updates as we make progress. If you signed up recently and can’t log in to MCP, please contact our support team for assistance.
https://zapier.com/app/get-help
We appreciate your patience while we work to resolve this issue.