Creating new Zaps via Forms Actions panel seeing errors
Resolved·Degraded performance

We are happy to report that the issue affecting the ability to create zaps from the actions panel in Forms has been resolved. Earlier today, some users encountered a generic error message (“Something went wrong”) when attempting to create new zaps from the Forms actions panel. Existing zaps and other methods for creating zaps were not affected. Our engineering team identified and corrected a broken link that was causing this error, which was related to a recent product rebrand. Functionality has been fully restored, and users can now create zaps from the Forms actions panel as expected. We apologize for any inconvenience this may have caused.

Thu, Jan 15, 2026, 08:52 PM
(6 hours ago)
·
Affected components
Forms
Updates

Resolved

We are happy to report that the issue affecting the ability to create zaps from the actions panel in Forms has been resolved. Earlier today, some users encountered a generic error message (“Something went wrong”) when attempting to create new zaps from the Forms actions panel. Existing zaps and other methods for creating zaps were not affected. Our engineering team identified and corrected a broken link that was causing this error, which was related to a recent product rebrand. Functionality has been fully restored, and users can now create zaps from the Forms actions panel as expected. We apologize for any inconvenience this may have caused.

Thu, Jan 15, 2026, 08:52 PM

Investigating

We are currently investigating an issue impacting the ability to create new Zaps directly from the Forms actions panel Users attempting to use this specific flow may encounter an error at the moment. This issue affects only the creation of new Zaps initiated via the Forms actions panel. Existing Zaps and other methods of creating Zaps remain operational. A workaround is available for the time being: You can create a new Zap manually from the dashboard, but use the "Form Submission Created" Trigger. Inside this trigger, select the Page and the Form associated Inside the Forms panel after, upon refresh, you should see the Form connected under the "Actions Tab" Our engineering team is actively working to identify the root cause and restore full functionality. We will provide further updates as more information becomes available.

Thu, Jan 15, 2026, 07:29 PM(1 hour earlier)