This issue is now resolved and all Tables functionality should return to normal. Any errored runs due to this incident were replayed. Thank you for your patience, and if you are still running into any issue, please reach out to Support for assistance: https://zapier.com/app/get-help
Resolved
This issue is now resolved and all Tables functionality should return to normal. Any errored runs due to this incident were replayed. Thank you for your patience, and if you are still running into any issue, please reach out to Support for assistance: https://zapier.com/app/get-help
Monitoring
Between 11:50 AM and 11:53 AM ET (4:50 PM to 4:53 PM UTC) on January 12, 2026, some users may have experienced temporary timeouts or an inability to access their Tables.
Some Zap runs were placed on hold status as a result of this timeout.
Tables and some frontend services reliant on tables also timed out during this timeframe
This issue has now been resolved, and normal functionality has been restored. We apologize for any inconvenience this may have caused. Please contact us at zapier.com/get-help if you have any questions!