Our team has implemented a fix, and all app images are now displaying correctly in Zapier's App Directory. If you're still seeing some broken images, please refresh your browser's cache and cookies, then load the page again. Many thanks for your patience! The support team is always happy to help if you have any questions: zapier.com/get-help
Resolved
Our team has implemented a fix, and all app images are now displaying correctly in Zapier's App Directory. If you're still seeing some broken images, please refresh your browser's cache and cookies, then load the page again. Many thanks for your patience! The support team is always happy to help if you have any questions: zapier.com/get-help
Identified
We've identified an issue where some images are not rendering correctly in the app directory (https://zapier.com/apps). You may see broken image icons in their place. Our team is actively working on addressing this issue, and we'll be providing updates periodically until the issue is fully resolved. Many thanks for your patience! If you have any questions, please reach us at: zapier.com/get-help