This issue is now resolved and all MCP functionality should return to normal. Thank you for your patience, and if you are still running into any issue, please reach out to Support for assistance: https://zapier.com/app/get-help
Resolved
This issue is now resolved and all MCP functionality should return to normal. Thank you for your patience, and if you are still running into any issue, please reach out to Support for assistance: https://zapier.com/app/get-help
Monitoring
From 00:45 AM UTC to 3:17 PM UTC we experienced a service disruption affecting MCP tool executions. During this time, some requests were temporarily unavailable and returned 500 or 503 errors. Our systems automatically restarted the affected services, and we worked to restore normal operation as quickly as possible.