Zaps using instant triggers experienced a temporary delay
Resolved

We identified an issue where Zaps using instant triggers did not fire as expected for a subset of users between December 18, 04:50–05:27 UTC. At 4:17 UTC today, December 19, our team identified the issue and recovered the hooks that did not execute during the impacted window. If you experience any further issues, please contact support by going to: https://zapier.com/app/get-help

Fri, Dec 19, 2025, 04:54 PM
(12 hours ago)
·
Affected components

No components marked as affected

Updates

Resolved

We identified an issue where Zaps using instant triggers did not fire as expected for a subset of users between December 18, 04:50–05:27 UTC. At 4:17 UTC today, December 19, our team identified the issue and recovered the hooks that did not execute during the impacted window. If you experience any further issues, please contact support by going to: https://zapier.com/app/get-help

Fri, Dec 19, 2025, 04:54 PM

Monitoring

At 4:17 UTC today, December 19, our team identified the issue and recovered the hooks that did not execute during the impacted window. If your Zaps use instant triggers, some runs that should have happened between 04:50-05:27 UTC on December 18 were delayed and have since been replayed by our team. No further action is required on your part. The underlying issue which led to this has been resolved, and future Zap Runs should run on time as expected. We will also continue to monitor to ensure normal operations. If you notice any issues please feel free to reach out to our support team.

Fri, Dec 19, 2025, 04:45 PM

Investigating

We identified an issue where Zaps using instant triggers did not fire as expected for a subset of users between December 18, 04:50–05:27 UTC. The issue has been addressed, and the webhooks that did not execute during this window were recovered at December 18, 15:23 UTC. Instant triggers are now operating normally. We are monitoring to ensure continued stability. No action is required from users.

Fri, Dec 19, 2025, 03:44 PM(1 hour earlier)