Degraded performance leading to slow or failed loading of folders and Zaps
Resolved·Degraded performance

We are happy to report that the issue causing degraded performance that led to slow or failed loading of folders and applications, and delays when executing templates has been resolved. Our team has implemented a fix, and performance has returned to normal. If you are still experiencing any issues, please contact our support team. We apologize for any inconvenience this may have caused.

Tue, Dec 9, 2025, 04:18 PM
(1 week ago)
·
Affected components
Updates

Resolved

We are happy to report that the issue causing degraded performance that led to slow or failed loading of folders and applications, and delays when executing templates has been resolved. Our team has implemented a fix, and performance has returned to normal. If you are still experiencing any issues, please contact our support team. We apologize for any inconvenience this may have caused.

Tue, Dec 9, 2025, 04:18 PM

Monitoring

Our team has implemented a fix for the ongoing issue leading to slow or failed loading of folders and applications, and delays when executing templates. We will be monitoring this implemented fix, and will provide updates as soon as this incident is fully resolved.

Tue, Dec 9, 2025, 03:52 PM(25 minutes earlier)

Investigating

We are currently investigating an issue causing degraded performance for some users, leading to slow or failed loading of folders and Zaps. Our team has identified the root cause and is actively working on a fix. We will provide further updates as they become available. Please reach out to our Support team if you need any immediate assistance.

Tue, Dec 9, 2025, 03:05 PM(47 minutes earlier)