Support Service Interruption
Resolved·Degraded performance

Our support services are fully functional

Fri, Dec 5, 2025, 09:51 AM
(8 hours ago)
·
Affected components
Updates

Resolved

Our support services are fully functional

Fri, Dec 5, 2025, 09:51 AM

Monitoring

There was a brief outage which interrupted our ability to provide Support Services to our customers. The issue has been reported as resolved however we will continue to monitor any further impact Thanks for your patience.

Fri, Dec 5, 2025, 09:32 AM(19 minutes earlier)

Identified

A third-party support platform we depend on is affected by an outage at its hosting provider. This may result in delays to ticket processing and extended response times. We appreciate your understanding and patience.

Fri, Dec 5, 2025, 09:13 AM(18 minutes earlier)