Cloudflare Outage Impacting Some Integrations
Resolved·Degraded performance

Earlier today (November 18th), upstream incidents with Cloudflare and OpenAI caused errors and delays for several integrations. The main error was 'There is an internal server error on Cloudflare's network.' OpenAI's login issue is resolved. We replayed all missed webhook events and unpaused the affected Zaps as soon as Cloudflare error rates dropped to zero. No data loss should be experienced. Thank you for your patience while our team addressed this issue!

Tue, Nov 18, 2025, 10:16 PM
(7 hours ago)
·
Affected components
Updates

Resolved

Earlier today (November 18th), upstream incidents with Cloudflare and OpenAI caused errors and delays for several integrations. The main error was 'There is an internal server error on Cloudflare's network.' OpenAI's login issue is resolved. We replayed all missed webhook events and unpaused the affected Zaps as soon as Cloudflare error rates dropped to zero. No data loss should be experienced. Thank you for your patience while our team addressed this issue!

Tue, Nov 18, 2025, 10:16 PM

Resolved

Earlier today (November 17th), upstream incidents with Cloudflare and OpenAI caused errors and delays for several integrations. The main error was 'There is an internal server error on Cloudflare's network.' OpenAI's login issue is resolved. We replayed all missed webhook events and unpaused the affected Zaps as soon as Cloudflare error rates dropped to zero. No data loss should be experienced. Thank you for your patience while our team addressed this issue!

Tue, Nov 18, 2025, 10:15 PM

Monitoring

The upstream issue has been resolved, and our team is continuing to monitor the affected integrations for any remaining errors.

Tue, Nov 18, 2025, 04:00 PM(6 hours earlier)

Investigating

We are currently investigating an issue that began around Tuesday, November 18, 2025, at 2:55 PM UTC. This issue is affecting several integrations and appears to be related to upstream incidents with Cloudflare.

  • What’s happening: We are observing errors related to Cloudflare’s network impacting various integrations, including RSS, HubSpot, and Webhooks. Hooks themselves are not impacted—only Hooks connected to integrations affected by the Cloudflare outage may experience issues.

  • Impact: Users may experience intermittent errors or failures when using these integrations. Any impacted Hooks will be replayed once the issue is resolved.

  • Current Status: Investigating. Our team is actively monitoring the situation and coordinating with our upstream providers.

  • Next Steps: We are assessing the full impact and will provide updates as we learn more from our providers and our internal systems.

We apologize for any inconvenience this may cause.

Tue, Nov 18, 2025, 03:47 PM(12 minutes earlier)