Some users may experience delays in Google Sheets triggers
Monitoring

We are still seeing some reports of 30-40 minute delays for Google Sheets triggers. Our engineering team is actively working with our partners at Google to get this issue sorted out. Google's team has confirmed there is indeed a processing issue, and they are working through a backlog of previous webhook requests. As they work through the backlog, we should see improvement and an eventual resolution of the delays. We will share any further updates as they are made available. Thank you for your patience as our teams continue to work on this!

Tue, Nov 18, 2025, 10:22 PM
(7 hours ago)
·
Affected components

No components marked as affected

Updates

Monitoring

We are still seeing some reports of 30-40 minute delays for Google Sheets triggers. Our engineering team is actively working with our partners at Google to get this issue sorted out. Google's team has confirmed there is indeed a processing issue, and they are working through a backlog of previous webhook requests. As they work through the backlog, we should see improvement and an eventual resolution of the delays. We will share any further updates as they are made available. Thank you for your patience as our teams continue to work on this!

Tue, Nov 18, 2025, 10:22 PM

Monitoring

Tue, Nov 18, 2025, 03:58 PM(6 hours earlier)

Investigating

We are aware that some users are experiencing delays in receiving Google Sheets webhooks, specifically for the 'New Spreadsheet Row' trigger. This issue began around November 12th and is likely related to a Google Incident. Our team is actively investigating the root cause and working on a resolution. We apologize for any inconvenience this may cause and will provide further updates as more information becomes available.

Sat, Nov 15, 2025, 01:25 AM(3 days earlier)