Connection Issues with Google Apps
Resolved

The issue affecting Google app connections has been resolved. Some data may have been lost while Google accounts were disconnected.

Reconnecting affected accounts will help ensure everything continues to work as intended.

If you're still experiencing issues, please contact Support: https://zapier.com/app/get-help

Thank you for your patience.

Mon, Jul 21, 2025, 04:03 PM
(2 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

The issue affecting Google app connections has been resolved. Some data may have been lost while Google accounts were disconnected.

Reconnecting affected accounts will help ensure everything continues to work as intended.

If you're still experiencing issues, please contact Support: https://zapier.com/app/get-help

Thank you for your patience.

Mon, Jul 21, 2025, 04:03 PM

Investigating

We’re currently investigating an issue that may be causing connection expiration for Google Apps. This appears to be related to an ongoing incident with Google Cloud services, which is tracked here: https://status.cloud.google.com/incidents/8cY8jdUpEGGbsSMSQk7J.We’re monitoring the situation closely and will provide updates as we learn more. Thank you for your patience.

Fri, Jul 18, 2025, 05:53 PM(2 days earlier)