Possible delays in polling triggers
Resolved·Degraded performance

We have resolved the issues related to increased latency across multiple services.

Thu, Aug 21, 2025, 08:03 PM
(1 month ago)
·
Affected components
Updates

Resolved

We have resolved the issues related to increased latency across multiple services.

Thu, Aug 21, 2025, 08:03 PM

Monitoring

We have a fix regarding the issue with increased latency across multiple services. Things are improving, and we are actively monitoring this issue.

Thu, Aug 21, 2025, 07:30 PM(33 minutes earlier)

Investigating

We are currently investigating reports of delays in Zaps that use polling based triggers.

We are continuing to investigate, and update this page once more information is available.

Thu, Aug 21, 2025, 06:33 PM(56 minutes earlier)