Issues loading Zaps and folders
Resolved

This incident has been resolved.

Mon, Aug 25, 2025, 04:30 PM
(1 month ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Mon, Aug 25, 2025, 04:30 PM

Investigating

We're currently experiencing an issue where users may encounter difficulties loading Zaps and folders.

We'll be updating this page as we get further information. If you need help, please contact Support: https://zapier.com/app/get-help

Mon, Aug 25, 2025, 03:52 PM(38 minutes earlier)