Todoist issues
Incident Report for Zapier
Resolved
Todoist is operating normally again. If you don't have autoreplay enabled, consult your task history to replay any failed tasks.
Posted Mar 23, 2016 - 06:30 PDT
Identified
Todoist seems to be experiencing issues, which may cause actions to fail. We're monitoring the situation and will post an update here when we know more.
Posted Mar 23, 2016 - 06:21 PDT
This incident affected: Apps.