Mixpanel is DOWN
Incident Report for Zapier
Resolved
Mixpanel is returning elevated 503s.
Posted 8 months ago. Feb 20, 2018 - 09:38 PST
Update
Mixpanel is returning elevated 503s.
Posted 9 months ago. Feb 01, 2018 - 10:53 PST
Identified
Mixpanel is returning elevated 503s.
Posted 9 months ago. Feb 01, 2018 - 10:53 PST
This incident affected: Apps.