Zap editor errors when adding Filter steps
Incident Report for Zapier
Resolved
Filter steps can be added and edited again.

During this issue, Zap workflows that already used Filters continued to work normally.
Posted Apr 15, 2021 - 10:08 PDT
Investigating
It's not currently possible to add new Filter steps into the Zap editor, so our team is investigating a repair.

Zap workflows that already use Filters continue to work normally.
Posted Apr 15, 2021 - 09:21 PDT
This incident affected: Website.