Trello issues
Incident Report for Zapier
Resolved
Everything is back to normal.
Posted 11 months ago. Sep 06, 2018 - 06:47 PDT
Identified
Trello is currently experiencing an outage which is causing Zaps to fail. We'll update this incident with more information when it becomes available.
Posted 11 months ago. Sep 06, 2018 - 06:30 PDT
This incident affected: Apps.