JotForm isues
Incident Report for Zapier
Resolved
This incident has been resolved.
Posted 23 days ago. Aug 28, 2018 - 03:44 PDT
Identified
JotForm is currently experiencing an outage, and Zaps are not functioning at this time. We are in contact with their team and will update this issue when we have more information.
Posted 23 days ago. Aug 28, 2018 - 01:42 PDT
This incident affected: Apps.