We're currently experiencing issues which could result in delayed Task execution
Incident Report for Zapier
Resolved
We have resolved the issue and Tasks are back up and running normally once again.
Posted about 1 month ago. Apr 22, 2019 - 22:50 PDT
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Apr 22, 2019 - 22:46 PDT
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Apr 22, 2019 - 20:10 PDT