Site Slowdown and Errors
Incident Report for Zapier
Resolved
This incident has been resolved - Zapier.com and all Zaps should now be working properly.
Posted Sep 20, 2018 - 17:15 PDT
Monitoring
We have implemented a fix for this and Zapier.com and related pages should now be up and running. We are continuing to monitor to ensure everything looks good.
Posted Sep 20, 2018 - 16:24 PDT
Investigating
We're investigating an issue causing slowdown and loading errors across the Zapier Dashboard and other Zap pages. Some delays may occur with processing Tasks. Our engineering team is looking into this and will have an update as soon as possible.
Posted Sep 20, 2018 - 15:42 PDT
This incident affected: Website, Developer Platform and Zaps (Polling Triggers).