Zapier Dashboard Down
Incident Report for Zapier
Resolved
We've resolved the issue and the website and dashboard and website should be back to normal now. Of course if you have any issues please feel free to reach out to support.
Posted 6 months ago. Jan 24, 2019 - 03:02 PST
Identified
We have currently identified an issue with the Dashboard and other pages not loading correctly when users login. We're actively working on a solution. Please subscribe for an update as soon as we resolve the issue.
Posted 6 months ago. Jan 24, 2019 - 02:59 PST
This incident affected: Website.