Zap Editor redirecting to blank page
Incident Report for Zapier
Resolved
We've fixed the issue with editing Zaps, and it's live on the site. You should be able to create and edit Zaps normally now. Please contact us if you have any questions: https://zapier.com/app/contact-us
Posted about 2 months ago. Apr 27, 2018 - 12:24 PDT
Identified
If you're creating or editing a Zap, you may see a blank page after selecting the trigger or action. We're working on a fix to resolve this. Subscribe to this incident for further updates and when it is resolved.
Posted about 2 months ago. Apr 27, 2018 - 11:31 PDT
This incident affected: Apps.