The Zapier site is currently experiencing some issues
Incident Report for Zapier
Resolved
Everything should be back to normal now.

Zaps will not have been affected. This was primarily for users attempting to login, and some parts of the site.
Posted 8 months ago. Nov 28, 2018 - 20:56 PST
Update
We are continuing to work on a fix for this issue.
Posted 8 months ago. Nov 28, 2018 - 20:12 PST
Identified
We're currently investigating an issue with our servers preventing some users from being able to access the site.

Please follow for updates.
Posted 8 months ago. Nov 28, 2018 - 20:10 PST
This incident affected: Apps.