Google Sheets Slow Request Times
Incident Report for Zapier
Resolved
Everything seems to be back to normal.
Posted 4 months ago. Jun 09, 2018 - 18:57 PDT
Identified
Google Sheets are currently experiencing very slow request times.
Posted 4 months ago. Jun 09, 2018 - 17:56 PDT
This incident affected: Apps.