Trello Slowdown
Incident Report for Zapier
Resolved
Everything seems to be back to normal.
Posted 5 months ago. Jul 31, 2017 - 09:15 PDT
Identified
Trello API calls have slowed down and will be delayed.
Posted 5 months ago. Jul 31, 2017 - 08:44 PDT
This incident affected: Apps.