Zapier.com is Slow or Unresponsive
Incident Report for Zapier
Resolved
We’ve isolated the source of the problem and deployed a fix. Customers should not be seeing delays or errors when editing or viewing Zaps. At this time service is restored to all components.

Our engineers are continuing to monitor our systems but there is no reason to suspect this problem will return.

Thank you for your patience and understanding. If you encounter any problems or have any questions, please contact us via our help page at https://zapier.com/help
Posted May 31, 2022 - 19:06 PDT
Monitoring
We have identified a potential cause of the problem and our engineers have deployed a workaround. At this time we see far fewer errors when using Zapier.com pages and Zap Runs continue to be processed as normal.

Our response team is continuing to monitor the problem and is working to isolate the root cause.

We will provide another update by 2:30 UTC.
Posted May 31, 2022 - 18:39 PDT
Investigating
We’re currently seeing slow performance across many Zapier.com pages. Users may see “503 Service Temporarily Unavailable” or "500 Internal Server Error" messages when trying to access the following on Zapier.com:

- Zap Editor
- Zap History
- My Connections
- Zapier Apps
- Support Contact Form
- Developer Platform

Our monitors indicate Zap Runs and Tasks are processing normally.

We’re currently investigating this issue and will work to mitigate the impacts. We’ll update the StatusPage with further details by 01:45 UTC // 18:45 PT.

We appreciate your patience while we resolve the issue.
Posted May 31, 2022 - 17:44 PDT
This incident affected: Zaps (Instant Triggers, Polling Triggers, Searches & Writes) and Website, Apps, Developer Platform.