Digest, Storage, Sub-Zap by Zapier steps may return 503/errors
Incident Report for Zapier
Resolved
Our engineers have been monitoring the fix implemented earlier to address the database outage in our Storage by Zapier app and are satisfied with the results. This incident is now resolved!

Between 2022-07-05 at 22:00:00 and 2022-07-06 at 10:45:00 UTC, a Storage by Zapier outage caused Zap Runs to return 503 errors. This outage also impacted Digest by Zapier and Sub-Zap by Zapier, as those apps run on the same service.

On 2022-07-06 at 11:10:00 UTC, our engineers were able to identify and implement a fix to address the issue causing the Storage by Zapier outage.

We’ve replayed the errored Zap Runs that occurred during the outage timeframe. At this time, Zap Runs and tasks should appear in your Zap History as expected. No action is needed from Zapier customers.

If you notice any issues with Zap Runs during the outage window, please reach out to our Support team here:

https://zapier.com/app/get-help
Posted Jul 06, 2022 - 11:41 PDT
Monitoring
Hi all,

We've implemented a fix to address a database outage Storage by Zapier, and services relying on it. The fix has now mitigated those impacts, and you should be able to continue using Storage by Zapier, Digest by Zapier and Sub-Zap by Zapier.

The fix was implemented at Wednesday 6 July 2022 10:58 UTC and we'll continue monitoring and updating this StatusPage within the next 24 hours once we're confident the fix has fully resolved the issue.

For any failed Zap run, you're able to replay these, as per: https://zapier.com/help/manage/tasks/replay-failed-tasks-in-zaps. For our Pro plan users and up, autoreplay—when enabled—will take care of replaying:

https://zapier.com/help/manage/tasks/replay-failed-tasks-in-zaps

We have also asked our engineers to help identify any failed Zap run and replay those from our end, but we're still waiting for an update on this.

If you have further questions, please reach out to our Support Team here: https://zapier.com/app/get-help.
Posted Jul 06, 2022 - 04:14 PDT
Investigating
Hi everyone,

We're currently investigating an issue with our Storage by Zapier app integration, which also affects Digest by Zapier and Sub-Zap by Zapier.

You may see:

- Zap runs using any of the above app integrations
- Testing any of these app integrations in the Zap editor
- Returning 503 errors or "internal errors"

We have identified these issues to have started at Tuesday 5 July 2022, at 22:00 UTC—and is currently under active investigation by our team of engineers.

We apologize for this inconvenience and will keep you up to date as we make progress.

Kindest regards,
Zapier Support
Posted Jul 06, 2022 - 03:41 PDT
This incident affected: Zaps (Instant Triggers, Polling Triggers, Searches & Writes) and Apps.