Polling Trigger Zaps Slowed Down
Incident Report for Zapier
Resolved
Things look fine again, we don't expect any Zaps to have missed triggers but if you notice anything -- please contact support at contact@zapier.com!
Posted 9 days ago. Sep 12, 2017 - 11:08 PDT
Investigating
We're investigating an issue with Polling Zaps (any Zap that isn't an Instant Trigger). More information soon!
Posted 9 days ago. Sep 12, 2017 - 10:16 PDT