Contact Us form broken
Incident Report for Zapier
Resolved
This incident has been resolved.
Posted 2 months ago. May 10, 2019 - 07:47 PDT
Identified
We have found the issue and expect to have a fix going out in about 30m.
Posted 2 months ago. May 10, 2019 - 06:56 PDT
Investigating
Since 12:30pm UTC, most of the routes through our Contact Us form are broken. Please select "Something else" as topic or email us at contact@zapier.com while we fix the form.
Posted 2 months ago. May 10, 2019 - 06:32 PDT