Issue with Delay by Zapier
Incident Report for Zapier
Resolved
All delayed tasks have been released. Tasks with Delay steps should be releasing normally now . If you have any troubles, please write to us from https://zapier.com/contact-us
Posted Jun 30, 2020 - 06:00 PDT
Investigating
We are currently investigating an issue that is causing Delay by Zapier steps to not release at the expected time. You may notice a "Waiting" status in the Task History and a delay in the processing of Action steps that follow.
Posted Jun 30, 2020 - 03:34 PDT