JotForm Is Experiencing Timeouts
Incident Report for Zapier
Resolved
JotForm is experiencing extreme timeouts - we've slowed access to the JotForm API until it is resolved. We continue monitoring the situation. All other services are healthy.
Posted May 10, 2016 - 11:58 PDT
Identified
JotForm is experiencing extreme timeouts - we've slowed access to the JotForm API until it is resolved. We continue monitoring the situation. All other services are healthy.
Posted May 10, 2016 - 11:51 PDT
This incident affected: Apps.