We're currently experiencing issues which could result in delayed Task execution
Incident Report for Zapier
Resolved
This issue was related to the Salesforce incident from today. Our systems are back to normal now, but we are continuing to monitor the related Salesforce incident:
https://status.salesforce.com/incidents/3815
Posted 3 months ago. May 17, 2019 - 18:32 PDT
Investigating
We are currently investigating this issue.
Posted 3 months ago. May 17, 2019 - 12:22 PDT
This incident affected: Apps.