Airtable is currently down.
Incident Report for Zapier
Resolved
Everything seems to be back to normal.
Posted 3 months ago. May 23, 2018 - 23:56 PDT
Identified
Airtable is currently experiencing some performance issues. You will most likely be seeing all Zaps that use Airtable returning an error.

They are currently investigating and will broadcast any updates here: https://twitter.com/airtablestatus?lang=en

In the meantime we will keep a close eye on things and add any further updates here.
Posted 3 months ago. May 23, 2018 - 22:56 PDT
This incident affected: Apps.